设为首页加入收藏联系我们欢迎您登录艾迪飞培训官方网站,我们提供CCNA培训、CCNP培训、CCIE培训. 企业培训.专业认证考试.
980
当前位置:首页 > 资料文件

有关NAT技术的各种配置

发布时间:2013-11-18 09:02:00 点击:

*******************************全部采用端口************************ 
ISP分配的IP202.99.160.129 

interface fastethernet0/0 
ip address 192.168.1.1 255.255.255.0 
duplex auto 
speed auto 
in nat inside 
no shutdown 

interface fastethernet0/1 
ip address 192.168.2..1 255.255.255.0 
duplex auto 
speed auto 
in nat outside 
no shutdown 

ip nat pool OnlyYou 202.99.160.130 202.99.160.130 netmask 255.255.255.252 
//OnlyYou代表地址池的名称。 2个202.99.160.130是代表只用一个ip做转换后ip. 
access-list 1 permit 192.168.1.0 0.0.0.255 
access-list 1 permit 192.168.2.0 0.0.0.255 
ip nat inside source list1 pool OnlyYou overload 


***********************动态地址转换+端口*********************** 
ISP分配的IP 有:202.99.160.130~190 255.255.255.192 

Interface fastethernet0/1 
Ip address 192.168.1.1 255.255.255.0 
Ip address 192.168.2.1 255.255.255.0 secondary 
Duplex auto 
Speed auto 
Ip nat inside 
No shutdown 

Interface serial 0/0 
Ip address 202.99.160.129 255.255.255.192 
Duplex auto 
Speed auto 
Ip nat outside 
No shutdwon 

Ip nat pool OutPort 202.99.160.190 202.99.160.190 netmask 255.255.255.192 
Ip nat pool OutPool 202.99.160.130 202.99.160.190 netmask 255.255.255.192 
Ip nat inside source list1 pool OutPort //192.168.1.0段主机全部转成202.99.160.190 
Ip nat inside source list2 pool OutPool 
//出于访问ftp站点等考虑:192.168.2.0和192.168.3.0段主机全部 
//转成202.99.160.130到202.99.160.189中的所有地址。 
Access-list1 permit 192.168.1.0 0.0.0.255 
Access-list2 permit 192.168.2.0 0.0.0.255 
Access-list2 permit 192.168.3.0 0.0.0.255 


***********************静态地址转换*********************** 

ISP分配的IP地址是:211.82.220.80~211.82.220.87 
211.82.220.81 255.255.255.248 
要求Intranet上的Web.E-mail.Ftp.Media可以被外部访问. 
Interface fastethernet0/0 
Ip address 192.168.1.1 255.255.255.0 
Duplex auto 
Speed auto 
Ip nat inside 
No shutdown 

Interface fastethernet0/1 
Ip address 211.82.220.81 255.255.255.248 
Speed auto 
Duplex auto 
Ip nat outside 
No shutdown 

Ip nat pool Outpool 211.82.220.86 211.82.20.86 netmask 255.255.255.248 
Access-list 1 permit 192.168.1.2 0.0.0.255 
Access-list 1 permit 192.168.1.3 0.0.0.255 
Access-list 1 permit 192.168.1.4 0.0.0.255 
Access-list 1 permit 192.168.1.5 0.0.0.255 
Ip nat inside source list1 pool Outpool overload 
Ip nat inside source static 192.168.1.2 211.82.220.82 
Ip nat inside source static 192.168.1.3 211.82.220.83 
Ip nat inside source static 192.168.1.4 211.82.220.84 
Ip nat inside source static 192.168.1.5 211.82.220.85 


******************NAT影射**************************** 
如果ISP提供的IP地址比较多还可以,但如果不是的时候(如就两个时),一个用于内网地址转换,另一个用于对外网提供服务. 
ISP提供的内网上网IP 

Interface ethernet0 
Ip address 192.168.1.1 255.255.255.0 
Duplex auto 
Speed auto 
Ip nat inside 
No shutdown 
Interface fastethernet0/0 
Ip address 211.82.220.129 255.255.255.248 
Duplex auto 
Speed auto 
Ip nat outside 
No shutdown 

Access-list 1 permit 192.168.1.0 0.0.0.255 
Ip nat pool Everybody 211.82.220.130 211.82.220.130 network 255.255.255.252 
Ip nat inside source list1 pool Everybody overload 
Ip nat inside source static tcp 192.168.1.2 80 202.99.220.130 80 
Ip nat inside source static tcp 192.168.1.3 21 202.99.220.130 21 
Ip nat inside source static tcp 192.168.1.4 25 202.99.220.130 25 
Ip nat inside source static tcp 192.168.1.5 110 202.99.220.130 110 


*******************利用地址转换实现负载均衡******************** 
;当有如象腾讯公司似的多服务器时,使用路由器实现负载平衡,可以使它们有平等的访问机会. 
Interface fastethernet0/1 
Ip address 192.168.1.1 255.255.255.0 
Duplex auto 
Speed auto 
Ip nat inside 
No shutdown 

Interface fastethernet0/0 
Ip address 202.110.198.81 255.2555.255.248 
Duplex auto 
Speed auto 
Ip nat outside 
Access-list 1 permit 202.110.198.82 
Access-list 2 permit 202.110.198.83 
Access-list 3 permit 192.168.1.0 0.0.0.255 
Ip nat pool Webser 192.168.1.2 192.168.1.3 255.255.255.248 type rotary 
Ip nat pool Ftpser 192.168.1.4 192.168.1.5 255.255.255.248 type rotary 
Ip nat pool normal 202.110.198.84 202.110.198.84 netmask 255.255.255.248 
Ip nat inside destination list 1 pool Webser 
Ip nat inside destination list 2 pool Ftpser

    更多开班计划

    
    收缩